An archive of community.esquilo.io as of Saturday January 26, 2019.

%%Runtime error [cannot connect to host]

arnaud_lacour

I have a project that has been working fine since I received my esquilo board last week.
In DHCP, all was well.
When I switched to a static IP configuration, ( esquilo menu -> wifi network -> IP settings -> static), I started getting this message when attempting to open an HTTP connection to a public service:

%%Runtime error [cannot connect to host]

Since the only change had been the IP settings, I turned telnet on and logged on eos to attempt a ping.

eos> ping yahoo.com
Unable to resolve host

That pointed me to DNS. A quick look in the docs and I checked the DNS settings:

eos> netcfg dns server
DNS Address : 0.0.0.0

After a brief look through the esquilo menus, I found that the DNS server address is set not in the IP settings menu but in the network services menu.

I proceeded to set the DNS correctly and reset the esquilo board.

Unfortunately I had the same error again on the esquilo console:

%%Runtime error [cannot connect to host]

after checking in eos, I realized that the DNS server address update in the UI isn't saved.
You can however set directly in eos which does work:

eos> netcfg dns server
DNS Address : 0.0.0.0

eos> netcfg dns server 192.168.3.1

A quick verification confirms that the DNS address is now set correctly.

eos> netcfg dns server
DNS Address : 192.168.3.1

This should get your nuts to run until the next esquilo boot, upon which you will have to do this again, as this setting does not survive reboots.

hope this helps someone...

patrick

Thanks Arnaud,

Sorry for the trouble. This is a known issue that has been fixed and will go out in the next EOS release in a couple of weeks. Craig points out a new work-around in this thread: http://community.esquilo.io/t/is-wep-supported-wireless-security/46/8

Add this to your boot.nut and enable it to automatically run on boot:

system("netcfg dns server 8.8.8.8");
arnaud_lacour

neat. Thanks for the tip and sorry to have missed it in the other thread.