An archive of community.esquilo.io as of Saturday January 26, 2019.

New Esquilo reports Runtime error [the index ‘require’ does not exist]

cwagner2401

I took a program that runs on another Esquilo and tried to run it on the a new board and it reports that %%Runtime error [the index 'require' does not exist]. The code line that is failing is require("ADC");

All Squirrel libraries are enabled.

Please note that it isn't reporting that ADC is an issue. It's reporting that require is the issue.

Any help is appreciated.

Thanks.

JefferyS

Hi, it kind of sounds like your running an old firmware version. You might upgrade to the latest, there are instructions in the Documentation.

If not I would need to see more of your code, do you have anything above the "require" line. Sometimes code before it can make it look like the error was on that line.

Hope this helps,

Jeffery