An archive of community.esquilo.io as of Saturday January 26, 2019.

Is wep supported wireless security?

cswiger

Hi all - excited to get my board in today. I see on this page https://www.esquilo.io/docs/#!eos-shell that access point security types include wep.

However I'm unable to connect to my wireless network - have entered the correct password over and over and just get: Join Failed - Unable to join the selected network with the password entered.

My network is a little different - the access point is a Linksys WRT54G running dd-wrt v24RC7 on ip address 192.168.1.5 while my dhcp server is an OpenBSD 3.4 gateway at 192.168.1.1. The AP is set for WEP 64bt (10 hex digit) encryption.

Think I had wep still due to some older devices and guess I could update it.

patrick

I'm glad to hear the board made it to you safely. I'll fire up my dd-wrt router, try WEP out, and see if I can reproduce your problem.

patrick

I'm not able to connect to WEP either. I've captured a trace and created a bug to track it, but I'm not sure how long it will take to fix. We've tested mainly with WPA and WP2 as WEP is hardly used now a days due to security issues. Maybe a good time to switch to WPA if it's not too much of a hassle.

cswiger

No problem - just fired up another little router and was able to connect WPA2 Personal TKIP A-OK. Thanks for verifying!

On with the show.....

cswiger

Well, this is fun - have another AP setup with WPA security bridging clients into my main net, and setup with a static ip address. I'm able to access the Esquilo web page now, and have enabled telnet and can login to command line (yea!). I'm a command line kind of guy smile )

DNS was set for 0.0.0.0 - setting it at the web interface says it must reboot for changes to take effect, and when it comes back up it's set for 0.0.0.0. ???

Setting it in a telnet session with : eos> netcfg dns server d.d.d.d
it will now ping outside sites, like nest.esquilo.io - ok now it's working - successfully registered system id X with account Y

But if I reset it'll lose dns server again frowning

Re-set dns and I can access from cloud .esquilo.io, really cool!

patrick

The DNS persistence issue sounds like a bug. I'll look into it. Thanks for letting us know.

fhervias

Having the same issue with no being able to connect via WEP. I guess it is time to upgrade.

cswiger

Could it be unable to write to flash for config persistence? Write protected? If I open boot.nut and try to save it as another filename I get: Unable to save file flash:/test.nut.

Should have some quality time today to play from work wink

patrick

boot.nut is the only file name that can be used in the flash. The current use pattern is to put your code in there or add dofile()s to include libraries from the SD.

I've reproduced the DNS persistence issue. I think it is a logic bug that should be easy to fix, but will require an EOS update.

cswiger

Easy fix / workaround for those using static IP, w/o EOS update wink

boot.nut:
system("netcfg dns server 8.8.8.8");

and enable boot.nut on startup.

patrick

Duh. Of course. Great work-around. Thanks!

Scott_Shumate

WEP is supported on the station interface but not on the access point interface. I just did a test to make sure on an old Linksys router and it worked fine. There is probably some confusion with how WEP handles keys and the IDE WiFi network dialog isn't enforcing the restrictions. WEP uses hexadecimal keys of either 10 or 16 digits in length. Many routers allow the use of a human readable pass phrase that they automatically convert to the hexadecimal key requirement. Esquilo will not do this for you and expects the hexadecimal key.

If your WEP key is a pass phrase, then you can convert it to the hexadecimal key here: http://www.wepkey.com/

Let's use "Esquilo" as the pass phrase. The web page shows us that key 1 is 9730849EBD. We feed that to Esquilo by prefixing each hexadecimal byte with a percent sign "%". So to add this AP with WEP on the command line, use:

sta add MyWiFiNet wep %97%30%84%9E%BD

All that being said, I would strongly discourage the use of WEP because it is trivially easy to crack.

JefferyS

Hi, I put the system("netcfg dns server 8.8.8.8"); with my dns server ip. But not sure how to enable boot.nut on startup. It loads the file but I guess it doesn't run it. When I run it it does put in the dns ip address in Network Services.

Any help would be most appreciated.

Jeffery

patrick

To run the boot.nut on startup, check the "Run boot.nut Automatically" setting in the System menu. The menu is a drop-down in the top right corner of the web IDE.