An archive of community.esquilo.io as of Saturday January 26, 2019.

IE and Chrome browsers won’t refresh the web page

silenceofnothingness

The example programs will not work with IE-11 and chrome browsers. Oddly when I log on with my Galaxy note4 using chrome browser all examples work fine. I'm using a different computer than the one I use for loading and running the example programs. Can anybody figure this out? I would appreciate any help.

Scott_Shumate

We develop primarily on Chrome and just test on IE, Firefox, and Safari. Which examples are you having trouble with and what exactly is the issue? Are you running the nut that goes with the HTML in the example?

silenceofnothingness

Hi Scott
When I run the esquilo 3d example this is what happens.
I'm using the Freescale arduino shield with my esquilo board.
First I run esquilo3d.nut.
Then running IE-11 or Chrome on another computer I log on to esquilo typing the following: 10.10.10.1/sd/lib/demos/imu/imu.html.
The page is loading and everything looks good but when I rotate,tilt the board the web page is frozen not updating.
When I log on with my Android phone everything works correctly that is the figure is getting tilted rotated in real time.
As a matter of fact all the demos work with my Android phone.
This is happening with the other demos too for example IMU, the SPRINKLER.
By the way I tried this with three different computers with same results.
Thanks for your prompt reply.

Scott_Shumate

I put a Freescale IMU shield on my Esquilo and tried the Esquilo 3D and IMU demos. I did find an issue with Internet Explorer 11. There is an error thrown when when the ERPC timeout is not specified by the JavaScript. We'll fix this in the next release.

For all other browsers I tried, those two demos ran fine. Here are the configurations that worked:

Windows 7 64bit (WiFi Station mode)
- Chrome 48
- FireFox 43

Windows 10 32-bit (WiFi AP mode to 10.10.10.1)
- Chrome 48
- Firefox 40
- Microsoft Edge 25

Thanks for the feedback. If you don't mind, what version of Chrome did you have trouble with?

silenceofnothingness

Hi Scott,
Unfortunately the IT people at my work do not allow any other browser to be installed on the work computers. So,I installed the latest version of chrome browser on my home computer and all the example projects worked.Although is not very important, I found that some of the example webpages are rendered differently depending on what device I use to log on to esquilo. After I ran the function generator program and logged on with my laptop using the chrome browser the up/down arrow was showing on the webpage. I was able to adjust the values by clicking on the arrows. On the android phone using the latest chrome browser the arrows do not show, but I can edit the fields directly by typing in the desired value.
Tanks for your help

Scott_Shumate

Thanks for feedback. We haven't spent a lot of time on cross-browser compatibility for the demos. We do most of our development on the most recent version of Chrome and Safari. I know there are a few issues here and there on Firefox and IE. If you or anyone would like to contribute updates for other browsers we'd gladly accept them and incorporate them into the library.

Thanks again,
Scott