An archive of community.esquilo.io as of Saturday January 26, 2019.

Esquilo not connecting to local WiFi network

sidprice

I am trying to set up the Esquino to access my office WiFi, the setup sees my SSID and I enter the password but it dows not connect and the green LED does not shine.
Suggestions?
Sid

patrick

I'm sorry you are having trouble. A couple of questions:

  • Are you connecting to a WEP or WPA network?

  • Are there any odd characters (e.g. non-alphanumeric, spaces, etc.) in the SSID or the key?

sidprice

Hello Patrick,

Thank you for your prompt response, the network is WPA and it has an underscore "_" in the SSID. Many devices here in my office connect to the network without issues.
Sid.

patrick

Any chance the AP has MAC filtering on (i.e. you have to explicitly list the Esquilo MAC on the device for the AP to allow it to join)? That has gotten me more than a few times.

sidprice

There is no MAC filtering enabled,
Sid

patrick

Sid, again, I'm sorry for the problems. I appreciate your patience. If it's not too much trouble, could you try the "Pro" path at the bottom of the Quick Start online doc? It shows how to configure Wi-Fi over the the USB console.

http://www.esquilo.io/docs/#quick-start-pro-quick-start

First, scan to get your SSID and security type:

wifi scan

If the configuration of your network GUI stuck, you should see it if you run:

sta list

If it is there, please remove it with:

sta del <ssid> <security-type>

and add it back with:

sta add <ssid> <security-type> <key>

then try to join the network with:

sta join <ssid> <security-type>

then check the status with:

sta

The commands are documented here:

http://www.esquilo.io/docs/#!eos-shell

sidprice

Excellent, the green LED is now on and I can access the IDE with the browser from my desktop. I tried the "run some code" section but boot.nut is an empty file. Is that correct?
Sid.

patrick

That's great! Thanks Sid.

The empty boot.nut is not correct. I think a batch of boards went out with these empty, on accident. My apologies.

The default "get you going" contents are here:

Just copy the contents, paste it in the boot.nut file in the editor, and save the file to fix.

sidprice

Patrick, working great thanks for the excellent help,
Sid

sanit_sir

I just got the Esquillo today after waiting for 12 days. I plugged the power via usb
and tried to set up the wifi but I couldn't see the local wifi. I connected the console
from usb and ran the commands above but I still could not see my local.

Then I looked for the Esquillo menu and click the Wifi Radio. The country code is US.
I changed it to my country code (TH) and then I could see my local wifi.

Now, my Esquilo works now and my boot.nut file is empty. I went to the web esquiloio/lib/blob/master/boot/boot.nut copy/paste the code and run the code.
The led blinks.

Thank you,

Sanit

patrick

Thanks for the feedback. I'm sorry international shipping takes so long.

And especially thanks for mentioning the country code. I need to update the Quick Start with international instructions that include setting the country code.

sevej

So, what does one do if their wifi password does contain spaces or other disallowed characters? I have this situation.

Thanks!

patrick

@sevej Please try adding the network from the USB console. It's documented in the "Pro" path at the bottom of the Quick Start online doc.

http://www.esquilo.io/docs/#quick-start-pro-quick-start3

To add a network:

sta add <ssid> <security-type> <key>

where <security-type> is one of these: open, wep, wpa-tkip, wpa-aes, wpa2-tkip, wpa2-aes, or wpa2-mix

then try to join the network with:

sta join <ssid> <security-type>

then check the status with:

sta

The individual commands are documented in the "Wi-Fi Station" section here:

http://www.esquilo.io/docs/#!eos-shell1

sevej

Thank you, this worked!

If I understand correctly, if either the SSID or the key contain odd characters, they can be entered by using the ascii hex codes escaped with "%". So in the example shown, the SSID is "Google Starbucks" and it is entered as "Google%20Starbucks".

Thanks!

patrick

Excellent. Thanks for the update.

The %-escaped option from the GUI is a good one, but tougher to explain wink.

bluerondo7

The Quick Start approach didn't work for me, eventually gave up and was successful with the Pro Quick Start method through EOS Shell. I initially tried coolTerm (on Mac) and that didn't work either but Serial (decisive...) did work.

Thanks

SJM_JFK

Patrick, We just received our first Esquilo Air and I'm also having trouble joining a WiFi network. I've followed all of the steps you suggested to this point but when I tried to delete an SSID, I get an "Access point delete failed" message.

When I originally tried to connect to the network when connected to esquilo as a hotspot, I would see the network listed but every time I would try the password it would throw the error: "Cannot connect to network using this password".

I have the USB connection via a terminal instance. On my Windows laptop the encryption type shows wpa2 Personal. In eos it shows wpa2-aes. AP MAC filtering is disabled.

What am I missing?

patrick

Please forgive me if you've already tried the following, but:

  • Connect to the serial console
  • List your configured wifi networks with:

sta list

You should get something like:

eos> sta list
SSID                             Security  BSSID             Chan
-------------------------------- --------- ----------------- ----
mynet                             wpa2-aes  14:ee:a6:82:e4:96   11
  • Delete each network in the list like so:

sta del mynet wpa2-aes

Note: the security type (wpa2-aes in this instance) is a required parameter to the delete.

  • Scan for available networks with:

wifi scan

  • Find the network SSID you'd like to join and note its security type (e.g. wpa2-aes). If the SSID has any 'special' charactors (even spaces) it will be difficult to join.

  • Add the network with its SSID, security type, and key:

sta add mynet wpa2-aes mynetpw

  • Join the network with its SSID and security type:

sta join mynet wpa2-aes

  • Check the status of the join with:

sta

Thanks for trying Esquilo. I hope this works for you.

SJM_JFK

Yes Patrick, I tried those procedures.

I think there's something the unit doesn't like with the particular network we need to connect to.

I did successfully connect to a different wifi network without any issues at all.

Are there any SSID or key length/character limitations with the Air unit? Many other devices connect to this network without any issues.

patrick

The limitations we have on SSID and key are based on our input interface. For example, on the console, the command is white-space delimited, so whitespace in an SSID or key are ambiguous and not read correctly. Same goes for special characters.

There are work-arounds, like replacing spaces with '%20'. But I haven't done a thorough investigation of all the cases and come up with proper instructions. So it is difficult to say exactly how to enter your parameters without know what the values are.

The simple work-around (that ranges from no problem, to inconvenient, to impossible for different users) is to ensure the SSID and key don't have whitespace or special characters.

SJM_JFK

That must be the issue then. The key has a few special characters.

Would it be possible to accommodate special characters in the future? Our IT department won't change the key for our department needs.

patrick

It's a tough limitation if you don't have control of the SSID and key. I haven't tested this much, but from the IDE WiFi settings dialog, you may be able to get it to work by substituting the whitespace and special chars with encoding listed here:

http://www.w3schools.com/tags/ref_urlencode.asp

If you try it, please post your results.

SJM_JFK

That worked Patrick!

since I saw that there was one % character in the key, I added "25" after the % and it added the network to the STA just fine.

Thanks a million for your assistance!

patrick

Sweet! Thanks for letting us know that works. I really appreciate it.

JefferyS

Hi, this may not be related to this problem but I can never get Firefox on windows to work when selecting the wifi I want to connect to. I always have to use chrome. Haven't tried lately but I just received a new board and try it out again.

I thought I mentioned this with screen shots but maybe I just thought about it and got side tracked lol. I don't know if it's just a display problem or not but the display when setting up the wifi to connect to the network is a bit different between Firefox and Chrome.

Thanks,

Jeffery