An archive of community.esquilo.io as of Saturday January 26, 2019.

Esquilo bricked

smithh6622

Hi.
I just got my Esquilo. Plugged it in and started the Setup procedure. Instead of connecting to the access point, my finger slipped and I connected to my cable modem wifi by accident. Esquilo is no longer listed in the network list and I can't reset it to un-pair the bad connection. I can't connect to any other network either. The board appears to be brain dead.

Suggestions?

patrick

Is the green 'NETWORK' LED on? If so, this means it is connected to your cable modem wifi. When you get a connection like this the board disables it's AP.

The best way to change the WiFi config now, is over the USB console interface. Please see the "Pro" section of the Quick Start doc here: http://www.esquilo.io/docs/#quick-start-pro-quick-start. Follow the instructions there to get a terminal to the console over USB, first.

Then, list the configured WiFi stations with:

sta list

It should only have your cable modem. Something like:

eos> sta list
SSID                             Security  BSSID             Chan
-------------------------------- --------- ----------------- ----
cable                             wpa2-aes  aa:bb:cc:dd:ee:ff    5

Remove the configured network with:

sta del <ssid> <security-type>            (e.g. sta del cable wpa2-aes)

Now if you reset the board, the Esquilo AP should come back up and you should be able to redo you original setup.

Note: you can also just continue setup over the console, if you like. First, scan for networks:

wifi scan

Find the network you want to join and add it:

sta add <ssid> <security-type> <key>

And join it:

sta join <ssid> <security-type>

To check the status:

sta
smithh6622

Patrick,

OK. That worked. I can now talk to my Esquilo, however I can't connect to my real wifi network. I started over with the browser based setup. I fill in the prompts for SSID and PW, press join, and either nothing happens or I get a message that the network is not found. In either case I no longer have control and have to close the browser and start over.

my equipment is;

Max OS X 10.9.6
dlink internet/wifi router
password is 8 characters of upper/lower case and numbers

I've got the Mac, a PC, an Android phone, and in iPad all connected to the 'dlink' network.

Is the password a problem?
Too long?
Too short?

patrick

What security is your network using: WEP, WPA, WPA2, open? If it's WEP, we're having some trouble with it. It is an older protocol and is known to be insecure, so is not used much now. I'd suggest moving to WPA or WPA2 if possible/practical. We may end up deprecating support for WEP.

If you had to enter the SSID, I assume your network doesn't show up in the scan list?

I would try to complete it all from the USB console with the commands I listed above. If you network doesn't show up in list returned from wifi scan then I doubt you will be able to join. Hopefully it shows up in the list and doing a command line add followed by a join works better than the GUI.

smithh6622

Patrick

Update:
After using the "see a button, push it" method of diagnostics, I managed to get both of my Esquilos working. I uploaded the "Blinky" sketch, ran it, modified it, ran it again, and everything worked on both units.
The problem was when presented with a list of available networks, I clicked on the one I wanted, entered my password, and nothing. "Network not found". If i click on the join new network button, I get prompted for the SSID, the security type, and password and bingo it works. The missing security type question, when selecting from a list, was the key. That whole network selection process needs re-working.

New Problem:
Registered the first unit OK, unplugged it and tried to register the second unit, and now neither unit is recognized in the "Wifi Scan". I list the available network on my MAC, my iPad, and in a terminal with screen, and the Esquilos are no where to be found.

Now what?

patrick

Based on the context, I take it by 'registered' you mean associated with local network. If that's right, then what happens as a result is the Esquilo disable their APs. Now it is time to access them over the shared LAN. To do this you need their IP addresses. These are usually dynamically assigned, so they are difficult to find. The "Find My Esquilo" utility helps with this. Go to http://find.esquilo.io from any computer on the same local network and you should see both of your devices, their IP addresses, and local links to get at them.

Optionally, you can register each of them with our cloud site, the Esquilo Nest to get a convenient management portal to all your register devices. More info here: http://localhost:63342/esquilo_docs/index.html#!esquilo-nest