An archive of community.esquilo.io as of Saturday January 26, 2019.

EOS Release 0.4 Problem

JefferyS

I just updated to 0.4 and now I can't access my sd card.

I hope it didn't erase it.

Powered on and off several times, pulled the card while on and put it back in, no change.

Thanks,

Jeffery

Just checked, sd card is fine.

I synced the SD Card Library so I guess the SD card is there just not showing up in the IDE.

Scott_Shumate

Try clicking the refresh file list icon on the top right of the file list. It looks like this:

If that doesn't work, then try removing the card and reinserting it. Sometimes inserting the card slowly or slightly crooked can cause a mount failure when EOS gets a card insertion event but the card isn't fully inserted.

If that doesn't do it, then try rebooting the Esquilo with the card already inserted.

JefferyS

Thanks Scott. Not sure what was up last night but just turned it on and it's reading the card.

I did try the refresh, rebooting the card and pulling it out and reinserting it several times last night.

Guess it needed a good nights sleep lol

Jeffery

bluerondo7

I had the exact same problem. Tried all the same things but no luck until I decided to try Safari which worked right away. Was using Firefox. Went back to Firefox to see if it would then work but still doesn't work. Safari seems to be working nicely. Might be browser/js related issue.

Scott_Shumate

I was able to reproduce this on Firefox and it is a browser caching issue. It seems Firefox is caching the JavaScript for the previous release. I cleared the browser cache and the SD file list came right back. Note that reloading the page in the browser doesn't clear the cached JavaScript. We'll try to come with something less brute force than clearing the browser cache.