An archive of community.esquilo.io as of Saturday January 26, 2019.

Can’t turn off automatic boot.nut due to IDE starvation

tdsa

Hi everyone,

I'm pretty new to Esquilo. Long story short, I turned on the option to automatically launch boot.nut, but don't have a long enough delay in the code, so the IDE is starved and I can't turn off the setting. It seems similar to this issue from gwziebe. However, the link to the erase image provided as a solution is giving me a 404. Is that image still available? Thanks.

Scott_Shumate

You can temporarily disable the automatic boot.nut by holding down PROG after Esquilo starts booting but before the boot.nut runs. You can then access the IDE to correct it. This feature was added in EOS 0.3 so update to the latest EOS if you are running an earlier version.

https://www.esquilo.io/docs/#!eos-releases

The sequence is to apply power, wait 1 second, and then press and hold PROG for 3 seconds or so. If you press PROG too fast you'll enter the bootloader evidenced by a slow blinking status LED. If you wait too long after boot, then the boot.nut will start. If either happens, just remove power and try again.

tdsa

Awesome, this worked! Thanks!

rb1

Or just telnet in and enter "sq kill". Then you can access the IDE. Since my Esquilo is monitoring a cistern and pump in the basement, physical access is a pain.

SJM_JFK

Scott,

I got in an endless loop and lost comm. and tried the procedure about 20 times and it isn't killing the nut. Is there a way to kill it in the PROG mode?

Scott_Shumate

Sorry to hear you're having trouble disabling the boot nut. The timing on the button press can be a little tricky. We increased the time window to make it easier to trigger and it will be available in a future EOS release.

For now, use this special image to clear the automatic boot.nut flag. Follow the instructions at the EOS update page to install the image. You basically hold down PROG, plug in the USB to your PC, release PROG, and then copy this image to your ESQUILO drive that shows up on the PC. The LED will blink fast for an instant and then blink slow continuously. As soon as you see the slow blink, disconnect the USB and repeat the update with the latest EOS image found at the EOS release page.